Replace Vim in Mac OS X Lion

I want to develop rails in my Lion OS, but the default vim doesnt have +ruby enabled. Doing a new compile of vim, make and make install does not replace it automatically not like in linux. Probably I dont have my path properly setup, but I dont want to bother so this is what I do

# do this if you dont have mercurial installed yet
sudo port install mercurial
# do this if you havent downloaded vim code yet which is most likely if you did not have mercurial 
hg clone https://vim.googlecode.com/hg/ vim
cd vim
./configure   --enable-pythoninterp=yes --enable-rubyinterp=yes
make
make install
//now make install is not enough, lets replace the current
mv /usr/bin/vim /usr/bin/vim.orig
ln -s src/vim /usr/bin/vim
Though English is my country's official language it is not my native tongue. If you find anything wrong with my phrases, or any incorrect information, write it out loud in the comments section. The world will be a bit better that way.
Posted in Javascript

Leave a Reply

Your email address will not be published. Required fields are marked *

*

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong> <pre user="" computer="" escaped="">